Custom fonts do not work on the device

I have tried 3 different fonts. All work on the simulator. None work on the device (iPad). One of the fonts has a space in the font name, the others don't. The fonts are all located in the root of my project folder. Here's my build.settings file:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
settings =
{
        orientation =
        {
                default ="landscapeRight",
                content = "landscapeRight",
                supported =
                {
                        "landscapeLeft","landscapeRight"
                },
        },
        
        iphone =
    {
        plist =
        {
                MinimumOSVersion="4.0.0",
            UIStatusBarHidden = true,
            UIApplicationExitsOnSuspend = false,
            UIPrerenderedIcon = true,
            CFBundleIconFiles = {
                       "Icon.png", 
                       "Icon@2x.png", 
                       "Icon-72.png"
                        },
            UIAppFonts = {"FuturaDemiBold.ttf", "Futura Bold.ttf", "TRON.TTF"}
        },
    },
    
    androidPermissions =
    {
        "android.permission.INTERNET",
        "android.permission.ACCESS_NETWORK_STATE"
    },
 
}

Seen this?

http://blog.anscamobile.com/2011/07/custom-fonts-corona/

Verify you are doing everything laid out in the article, as custom fonts work for me.

Yes, I've done everything they say, double and triple checked. I've tried several fonts, both .ttf and .otf. All work on the simulator. None work on the iPad. Good times.

Banged my head against the wall with the same problem and finally decided it was time to move on and find another font. Now I test a custom font on several devices before I fall in love with it.

views:1670 update:2011/9/28 9:01:40
corona forums © 2003-2011