Why this resizing is happening?

Hello guys,

So I am asking some help because I am having problems while trying to develop one project and it is about using the Recipe app code that is here - http://developer.anscamobile.com/code/recipes-app-using-director-and-scrollview

So my problem is that the images of the recipes (those that scroll) are being all resized in the view of my Corona Simulator as in the device after building it as well. And I do not have knowledge on all of this just yet to get it solved so please, some help devs!

Below folow 2 links that show you exactly what is happening here:

1- http://cl.ly/3u3b2r2z180l0r0Q250j (using myTouch original project device)
2- http://cl.ly/1W1t102K130a1D0W1G1f (using iPhone 4 skin)

PS: This is happening only with the recipe images at all. With the Menu and Intro all are looking like okay so far and SO it make me think that the problem is about after have the recipe images inserted into the ScrollView group (in the code). All other images that do not use the class and so do not need to scroll are working as in the original project posted in the Ansca Codes page link I mentioned above.

PS: I`ve the config.lua (320width vs 480height) and build.settings ok.

Some Help??

Thanks in advance.
Rodrigo.

Hey Rodrigo :)

What are your zoom settings set to?

Try this for config.lua;

1
2
3
4
5
6
7
8
9
application =
{
content =
{
width = 320,
height = 480,
scale = "zoomEven"
}
}

If you use ZoomEven the device is still using the graphics @2x?

Hello Peach!! :)

I did use "letterbox" and "zoomEven" but there arent any visible changing! :\

Its is very strange what is happening btw. And it just happens with the images of the recipes (that in the project is the all content of it) and so must be scrolled. But the scroll does work, the problem is that is "resize" de images! Look - the image has: 320 pixel width and 1000 pixels height and so it should display taking all the display area of the iPhone (that is 320 width) and so let me scroll it until the end that is the size of the image`s height - 1000 pixels.

So I am not understanding nothing anymore...or maybe I never ever understood - at least by this start! :]

Mrs. Peach Pellen, tahnk you very much for the attention as always! ;)

Rodrigo.

Hey again,

Are you able to upload this somewhere so I can try to take a little look?

Peach :)

Hey Mrs. Peach Pellen,

Thank you very much for your attention!

For sure I would upload and share with you any of my projects...nevermind. :)

BUT the good news is that I`ve solved that issue I was having above Peach! ;)

I did declare one more "parameter" inside the command line:
myImage = display.newImage("myimage.png", true)

That way I got all the content beautifully showed on the display. So the problem was solved by just adding the param "TRUE" for the line! But as you know I am just a apprentice at all of this I did not even know about that optional param. :\

So one more time,

My best Regards Mrs. Pellen for all your help!

Rodrigo.

views:1586 update:2011/10/17 21:25:02
corona forums © 2003-2011