no puedo probar mis aplicaciones despues de darles build!!!

amigos espero que alguien me ayude, tengo un par de aplicaciones, les doy build, el sistema me crea los archivos apk para android pero cuando trato de instalarlo en mi dispositivo android no termina la instalacion y me muestra un error que dice la aplicacion no se ha instalado...alguien me puede ayudar?, no he tratado compilarlo para ios pero no se si me genere el mismo problema!!

Examina el sistema operativo de tu dispositivo android Alex, ¿es 2.2+?

si, olvide comentarlo es android 2.2 y cuando le doy build tambien lo compilo para la misma version pero sigo sin probar mis aplicaciones en un lugar diferente al emulador del sdk, no tengo un mac pero un amigo si, entonces apenas podre probarlo el fin de semana a ver si funciona!!!

Ten en cuenta que solo funciona a partir de 2.2. ¿En que dispositivo lo estas probando?

Lo que tambien me ha sucedido a mi es que a veces con un nombre reverso con numeros no me tira (lo de com.empresa.juego)

Prueba una aplicacion normal rollo HelloWorld a compilarla en APK y asi comprobaras si todo funciona correctamente.

si, trate aplicaciones sencillas como hello world y nas mas complejas como las que he ido creando pero nada...mi dispositivo es una tablet de 7"

Samsung galaxy tab wifi only de 7 o 3g? Yo lo pruebo en wifi y funciona bien.

Dime que datos pones cuando le das a build y que sistema operativo usas. Mejor si pones un pantallazo con los datos que pones antes de lanzar la build

ok!!

trabajo en windows 7, mi tablet es una MID 7" android 2.2. los campos de el formulario son:

package D.S
target: android 2.2
keystore: por defecto la que esta en la carpeta de corona sdk
key alias: andropiddebugkey

que mas datos te puedo dar?

en este video muestran mi tablet!!!
http://www.youtube.com/watch?v=ErJiv9Btlks

cambia lo de package "D.S" y pon algo asi como "com.alexram.juego". El nombre del package actua como reverso de dominio para la interpretacion de la aplicacion

voy a ensayar, gracias..

bueno, ya entrado en gastos, despues de tener la aplicaion al 100% como funciona eso del launch pad para montarlas en las diferentes tiendas?

¿Montarlas en diferentes tiendas?. El launchpad no hace eso. El launchpad sirve como guia y analítica de tus aplicaciones una vez las lanzas al app store o el android market.

Si lo miras en profundidad veras varios documentos sobre marketing y un grupo de partners de anscamobile que pueden hacerte reviews del juego en sus webs.

Además, si añades analiticas, veras tambien dentro del launchpad las sesiones del juego lanzado y los sistemas operativos usados.

ensaye lo de cambiarle el nombre del package y7 no me funciona..y en un emulador que descargue tampoco..

1. Vale, ¿tu tablet tiene marcada la opción de poder instalar aplicaciones que no sean del market?.

2. intenta poner el nombre del juego sin numeros "prueba" y el package algo asi como "com.alex.prueba"

3. Si es posible, reinstalate de nuevo el corona sdk por si hubiera habido algun problema en el instalador a la hora de poner el sdk de android.

si, mi tablet tiene habilitada la opcion de intalacion de software de terceros, de hecho la tablet no venia con el market original pero yo se lo instale, he instalado un sinfin de aplicaiones (desde las diferentes tiendas y descargadas de la red) y todas corren sin problemas.

al juego le puse: scenes, alpackage le di com.alex.prueba

he tratado desde dos computadores diferentes a los cuales habilite el sdk, de hecho por una formateada los reinstale hace poco pero aun nada.....no me corren...

A mi aveces las builds no me deja instalarlas pero ... es algo que me pasa de forma esporadica. Normalmente esto te puede pasar si hay algo raro con los iconos o con el manifiesto.

Pero claro, si has cogido un "HelloWorld" peladito y no te ha funcionado...

¿Has probado directamente el Helloworld ahora?. Es decir, poniendole com.alex.helloworld y probandolo directamente a ver si te funciona.

Puedes encontrarlo en samples dentro del directorio de corona. Copia el directorio de HelloWorld y pegatelo en documentos, ejecuta el main.lua desde el simulador y dale a build for android. Pon el package como com.alex.HelloWorld

Haz la prueba y asi vas desechando. Si el helloworld no te funciona entonces algo pasa con las builds en tu ordenador.

Tambien siendo suscriptor, puedes probar con una build anterior como la 700.

muchas gracias voy a ensayar!!! a ver que resulta de este experimento!!

no, definitivamente algo esta muy mal, trate nuevamente de instalar el helloworld con el n ombre del package que me diste y no corre y me muestra el mismo error

Entonces lo mejor que puedes hacer es enviar un email a soporte para ver si existe algun problema al crear la build y que te puedan ayudar, es que mas no se que puedo hacer.

muchas gracias por tu atencion y por tu tiempo!

views:1806 update:2011/12/31 9:35:10
corona forums © 2003-2011